EverPixel closed for maintenance
Resolved·Full outage

Dear Users,

Thank you for waiting, we have resolved the issue. We will keep in touch to make sure this issue wont happen again!

Thank you for your understanding.

ArcByte Team

Mon, Jan 19, 2026, 08:49 PM
(4 hours ago)
·
Affected components
EverPixel MC
Updates

Resolved

Dear Users,

Thank you for waiting, we have resolved the issue. We will keep in touch to make sure this issue wont happen again!

Thank you for your understanding.

ArcByte Team

Mon, Jan 19, 2026, 08:49 PM

Identified

Dear EverPixel MC Players,

We are currently closing the server for maintenance! More information, please find https://news.everpixelmc.com/190126/maintenance/

Thank you for your understanding!

ArcByte

Mon, Jan 19, 2026, 08:34 PM(14 minutes earlier)
Powered by

This is an ArcByte website | www.arcbytecn.com